Moby authz zero length regression
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 25.0.6+incompatible, 26.1.5+incompatible, 27.1.1+incompatible, 23.0.15, 26.1.5, and 2 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 proofs of concept on GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Moby is an open-source project created by Docker for software containerization. A security vulnerability has been detected in certain versions of Docker Engine, which could allow an attacker to bypass authorization plugins (AuthZ) under specific circumstances. The base likelihood of this being exploited is low. Using a specially-crafted API request, an Engine API client could make the daemon forward the request or response to an authorization plugin without the body. In certain circumstances, the authorization plugin may allow a request which it would have otherwise denied if the body had been forwarded to it. A security issue was discovered In 2018, where an attacker could bypass AuthZ plugins using a specially crafted API request. This could lead to unauthorized actions, including privilege escalation. Although this issue was fixed in Docker Engine v18.09.1 in January 2019, the fix was not carried forward to later major versions, resulting in a regression. Anyone who depends on authorization plugins that introspect the request and/or response body to make access control decisions is potentially impacted. Docker EE v19.03.x and all versions of Mirantis Container Runtime are not vulnerable. docker-ce v27.1.1 containes patches to fix the vulnerability. Patches have also been merged into the master, 19.03, 20.0, 23.0, 24.0, 25.0, 26.0, and 26.1 release branches. If one is unable to upgrade immediately, avoid using AuthZ plugins and/or restrict access to the Docker API to trusted parties, following the principle of least privilege.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- moby moby
From 19.03.0 · through 19.03.15; From 20.0.0 · through 20.10.27; From 23.0.0 · through 23.0.14; From 24.0.0 · through 24.0.9; From 25.0.0 · through 25.0.5; From 26.0.0 · through 26.0.2; From 26.1.0 · through 26.1.14; From 27.0.0 · through 27.0.3
- github.com/moby/mobyGo
From 20.10.0+incompatible · fixed in 25.0.6+incompatible; From 26.0.0+incompatible · fixed in 26.1.5+incompatible; From 27.0.0+incompatible · fixed in 27.1.1+incompatible
- github.com/docker/dockerGo
From 20.10.0+incompatible · fixed in 25.0.6+incompatible; From 26.0.0+incompatible · fixed in 26.1.5+incompatible; From 27.0.0+incompatible · fixed in 27.1.1+incompatible
- github.com/docker/dockerGo
From 19.03.0 · fixed in 23.0.15
- github.com/docker/dockerGo
From 26.0.0 · fixed in 26.1.5
- github.com/docker/dockerGo
From 27.0.0 · fixed in 27.1.1
- github.com/docker/dockerGo
From 24.0.0 · fixed in 25.0.6