Customer data leak via adjustments API endpoint in Sylius
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.12.19, 1.13.4, 1.9.12, 1.10.16, 1.11.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Sylius is an Open Source eCommerce Framework on Symfony. A security vulnerability was discovered in the `/api/v2/shop/adjustments/{id}` endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information. The issue is fixed in versions: 1.12.19, 1.13.4 and above. The `/api/v2/shop/adjustments/{id}` will always return `404` status. Users are advised to upgrade. Users unable to upgrade may alter their config to mitigate this issue. Please see the linked GHSA for details.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Sylius Sylius
fixed in 1.12.19; From 1.13.0 · fixed in 1.13.4
- sylius/syliusPackagist
From 1.12.0-alpha.1 · fixed in 1.12.19
- sylius/syliusPackagist
From 1.13.0-alpha.1 · fixed in 1.13.4
- sylius/syliusPackagist
fixed in 1.9.12
- sylius/syliusPackagist
From 1.10.0-alpha.1 · fixed in 1.10.16
- sylius/syliusPackagist
From 1.11.0-alpha.1 · fixed in 1.11.17