Skip to main content
← All vulnerabilities
CVE-2024-40094GHSA-H9MQ-F6Q5-6C8M

GraphQL Java (aka graphql-java) before 21.5 does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of ser

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 19.11, 20.9, 21.5
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

GraphQL Java (aka graphql-java) before 21.5 does not properly consider ExecutableNormalizedFields (ENFs) as part of preventing denial of service via introspection queries. 20.9 and 19.11 are also fixed versions.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • com.graphql-java:graphql-javaMaven

    fixed in 19.11

  • com.graphql-java:graphql-javaMaven

    From 20.0 · fixed in 20.9

  • com.graphql-java:graphql-javaMaven

    From 21.0 · fixed in 21.5

References 7

GitHub · graphql-java/graphql-java

GitHub · kabiri-labs/CVE-2024-40094