Skip to main content
← All vulnerabilities
CVE-2024-39614GHSA-F6F8-9MX6-9MX2BIT-DJANGO-2024-39614PYSEC-2024-59

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.0.7, 4.2.14
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containing specific characters.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • djangoPyPI

    From 5.0 · fixed in 5.0.7

  • djangoPyPI

    From 4.2 · fixed in 4.2.14

  • djangoPyPI

    From 5.0 · fixed in 5.0.7; From 4.2 · fixed in 4.2.14

References 4

docs.djangoproject.com

groups.google.com

djangoproject.com

GitHub · Abdurahmon3236/-CVE-2024-39614