Skip to main content
← All vulnerabilities
CVE-2024-39409GHSA-RF4Q-M23C-7Q8R

Adobe Commerce | Cross-Site Request Forgery (CSRF) (CWE-352)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that could allow an attacker to bypass security features and perform minor integrity changes on behalf of a user. The vulnerability could be exploited by tricking a victim into clicking a link or loading a page that submits a malicious request. Exploitation of this issue requires user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p9

  • magento/community-editionPackagist

    From 2.4.7-p1 · fixed in 2.4.7-p2

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p9

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    fixed in 2.4.4-p10

  • magento/community-editionPackagist

    2.4.4

References 1

helpx.adobe.com