Skip to main content
← All vulnerabilities
CVE-2024-39400GHSA-52FG-WJXM-PP44

DOM XSS through integrations can impact other admins

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by a DOM-based Cross-Site Scripting (XSS) vulnerability. This vulnerability could allow an admin attacker to inject and execute arbitrary JavaScript code within the context of the user's browser session. Exploitation of this issue requires user interaction, such as convincing a victim to click on a malicious link. Confidentiality and integrity impact is high as it affects other admin accounts.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p9

  • magento/project-community-editionPackagist

    through 2.0.2

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p2

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p7

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p9

  • magento/community-editionPackagist

    From 2.4.4-p1 · fixed in 2.4.4-p10

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

References 1

helpx.adobe.com