Skip to main content
← All vulnerabilities
CVE-2024-37389GHSA-H658-QQV9-QWV8

Apache NiFi: Improper Neutralization of Input in Parameter Context Description

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.27.0, 2.0.0-M4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • org.apache.nifi:nifi-web-ui

    From 1.10.0 · through 1.26.0; From 2.0.0-M1 · through 2.0.0-M3

  • org.apache.nifi:nifi-web-uiMaven

    From 1.10.0 · fixed in 1.27.0

  • org.apache.nifi:nifi-web-uiMaven

    From 2.0.0-M1 · fixed in 2.0.0-M4

References 1

lists.apache.org