Skip to main content
← All vulnerabilities
CVE-2024-36522GHSA-HHWC-GH8H-9RRP

Apache Wicket: Remote code execution via XSLT injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.1.0, 9.18.0, 8.16.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.wicket:wicket-util

    From 10.0.0-M1 · through 10.0.0; From 9.0.0 · through 9.17.0; From 8.0.0 · through 8.15.0

  • org.apache.wicket:wicket-utilMaven

    From 10.0.0-M1 · fixed in 10.1.0

  • org.apache.wicket:wicket-utilMaven

    From 9.0.0 · fixed in 9.18.0

  • org.apache.wicket:wicket-utilMaven

    From 8.0.0 · fixed in 8.16.0

References 2

lists.apache.org

openwall.com