Skip to main content
← All vulnerabilities
CVE-2024-36401GHSA-6JJ6-GM7P-FCVV

Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 2.23.6, 2.24.4, 2.25.2, 2.22.6
None on Exploit-DB, Metasploit or GitHub

Summary

GeoServer, an open source server for sharing and editing geospatial data, is affected by a vulnerability that lets unauthenticated users run arbitrary code on the server through specially crafted requests to standard OGC service parameters, affecting default installations. This means an attacker could potentially take full control of the affected server without needing any login credentials.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2, multiple OGC request parameters allow Remote Code Execution (RCE) by unauthenticated users through specially crafted input against a default GeoServer installation due to unsafely evaluating property names as XPath expressions. The GeoTools library API that GeoServer calls evaluates property/attribute names for feature types in a way that unsafely passes them to the commons-jxpath library which can execute arbitrary code when evaluating XPath expressions. This XPath evaluation is intended to be used only by complex feature types (i.e., Application Schema data stores) but is incorrectly being applied to simple feature types as well which makes this vulnerability apply to ALL GeoServer instances. No public PoC is provided but this vulnerability has been confirmed to be exploitable through WFS GetFeature, WFS GetPropertyValue, WMS GetMap, WMS GetFeatureInfo, WMS GetLegendGraphic and WPS Execute requests. This vulnerability can lead to executing arbitrary code. Versions 2.22.6, 2.23.6, 2.24.4, and 2.25.2 contain a patch for the issue. A workaround exists by removing the `gt-complex-x.y.jar` file from the GeoServer where `x.y` is the GeoTools version (e.g., `gt-complex-31.1.jar` if running GeoServer 2.25.1). This will remove the vulnerable code from GeoServer but may break some GeoServer functionality or prevent GeoServer from deploying if the gt-complex module is needed.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • geoserver geoserver

    From 2.23.0 · fixed in 2.23.6; From 2.24.0 · fixed in 2.24.4; From 2.25.0 · fixed in 2.25.2; fixed in 2.22.6

  • org.geoserver.web:gs-web-appMaven

    From 2.24.0 · fixed in 2.24.4

  • org.geoserver:gs-wfsMaven

    From 2.24.0 · fixed in 2.24.4

  • org.geoserver:gs-wmsMaven

    From 2.24.0 · fixed in 2.24.4

  • org.geoserver.web:gs-web-appMaven

    From 2.25.0 · fixed in 2.25.2

  • org.geoserver:gs-wfsMaven

    From 2.25.0 · fixed in 2.25.2

  • org.geoserver:gs-wmsMaven

    From 2.25.0 · fixed in 2.25.2

  • org.geoserver.web:gs-web-appMaven

    From 2.23.0 · fixed in 2.23.6

  • org.geoserver:gs-wfsMaven

    From 2.23.0 · fixed in 2.23.6

  • org.geoserver:gs-wmsMaven

    From 2.23.0 · fixed in 2.23.6

  • org.geoserver.web:gs-web-appMaven

    fixed in 2.22.6

  • org.geoserver:gs-wfsMaven

    fixed in 2.22.6

  • org.geoserver:gs-wmsMaven

    fixed in 2.22.6

References 5

GitHub · geoserver/geoserver

GitHub · geotools/geotools

GitHub · Warxim/CVE-2022-41852

osgeo-org.atlassian.net