Skip to main content
← All vulnerabilities
CVE-2024-35241GHSA-47F6-5GQ3-VX9CBIT-COMPOSER-2024-35241

Composer vulnerable to command injection via malicious git branch name

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.24, 2.7.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `status`, `reinstall` and `remove` commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid installing dependencies via git by using `--prefer-dist` or the `preferred-install: dist` config setting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • composer composer

    From 2.0 · fixed in 2.2.24; From 2.3 · fixed in 2.7.7

  • composer/composerPackagist

    From 2.0 · fixed in 2.2.24

  • composer/composerPackagist

    From 2.3 · fixed in 2.7.7

References 5

GitHub · composer/composer

lists.fedoraproject.org